【検証】IPv6 HSRP 設定

どうも、0 -Ray- です!

今回は仮想環境にて、IPv6のHSRP設定を検証したので、
結果をメモとして残そうと思います!

今回の記事でわかること   IPv6のHSRP設定方法
  IPv6のHSRP設定注意点

それでは行ってみましょう!

スポンサーリンク

検証環境

  • EVE-NG
  • Cisco IOL (Router/L3SW)

検証結果

設定

(config)#interface [任意のIF]
(config-if)#standby version 2

(config-if)#standby [group-number] ipv6 autoconfig
or
(config-if)#standby [group-number] ipv6 [任意のアドレス]

(config-if)#standby [group-number] [各種オプション]

>standby version 2
version 2でないとipv6に対応していないので必須になります。

>standby [group-number] ipv6 autoconfig
リンクローカルアドレスが自動生成されます。
多くの機器は基本的にリンクローカルアドレスしか使用できないので注意が必要です。

>standby [group-number] ipv6 [任意のアドレス]
ただ、機種によって通常のipv6も設定可能です。

>standby [group-number] [各種オプション]
ipv4と同じようなオプションが使えます。
(preempt,timer 等)


※注意点としてipv6を使用する際はipv6を使用できるような設定をする必要があります。
こちらの記事に記載したので、慣れてない方や思い出したい方は是非!

検証(構築)

構成

config

ipv6 unicast-routing
!
interface Ethernet0/1
no ip address
standby version 2
standby 10 ipv6 2001:192:168:10::100/64
standby 10 timers 1 3
standby 10 priority 105
standby 10 preempt delay minimum 60
ipv6 address 2001:192:168:10::10/64
ipv6 enable

ipv6 unicast-routing
!
interface Ethernet0/1
no ip address
standby version 2
standby 10 ipv6 2001:192:168:10::100/64
standby 10 timers 1 3
standby 10 preempt delay minimum 60
ipv6 address 2001:192:168:10::20/64
ipv6 enable

vlan 10
!
interface Ethernet0/0
switchport access vlan 10
switchport mode access
duplex auto
!
interface Ethernet0/1
switchport access vlan 10
switchport mode access
duplex auto
!
interface Ethernet0/2
switchport access vlan 10
switchport mode access
duplex auto

ipv6 unicast-routing
!
vlan 10
!
interface Ethernet0/0
switchport access vlan 10
switchport mode access
duplex auto
!
interface Vlan10
no ip address
ipv6 address 2001:192:168:10::1/64
ipv6 enable

検証(確認)

#ping ipv6 [任意のアドレス]
#show standby
#show standby brief

・IFをshutdownした際の切り替わり確認

上記で確認しました。

SW2#ping ipv6 2001:192:168:10::100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:192:168:10::100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/20 ms

SW2#ping ipv6 FE80::5:73FF:FEA0:A
Output Interface: vl 10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::5:73FF:FEA0:A, timeout is 2 seconds:
Packet sent with a source address of FE80::A8BB:CCFF:FE80:8000%Vlan10
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/21 ms

リンクローカルアドレス宛ての際はOutput Interfaceを入力します。
通常通り設定したユニキャストアドレスのvipも
自動生成のリンクローカルアドレスのvipも疎通できます。

RT1#show stan
Ethernet0/1 – Group 10 (version 2)
State is Active
5 state changes, last state change 00:11:06
Link-Local Virtual IPv6 address is FE80::5:73FF:FEA0:A (impl auto EUI64)
Virtual IPv6 address 2001:192:168:10::100/64
Active virtual MAC address is 0005.73a0.000a
Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
Hello time 1 sec, hold time 3 sec
Next hello sent in 0.272 secs
Preemption enabled, delay min 60 secs
Active router is local
Standby router is FE80::A8BB:CCFF:FE00:2010, priority 100 (expires in 2.960 sec)
Priority 105 (configured 105)
Group name is “hsrp-Et0/1-10” (default)

RT2#show stan
Ethernet0/1 – Group 10 (version 2)
State is Standby
4 state changes, last state change 00:27:06
Link-Local Virtual IPv6 address is FE80::5:73FF:FEA0:A (impl auto EUI64)
Virtual IPv6 address 2001:192:168:10::100/64
Active virtual MAC address is 0005.73a0.000a
Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
Hello time 1 sec, hold time 3 sec
Next hello sent in 0.720 secs
Preemption enabled, delay min 60 secs
Active router is FE80::A8BB:CCFF:FE00:1010, priority 105 (expires in 3.344 sec)
MAC address is aabb.cc00.1010
Standby router is local
Priority 100 (default 100)
Group name is “hsrp-Et0/1-10” (default)

Link-Local Virtual IPv6 addressが自動生成されていることがわかります。

RT1#show standby bri
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/1
10
105
P Active
local
FE80::A8BB:CCFF:FE00:2010
FE80::5:73FF:FEA0:A

RT2#show standby bri
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Et0/1
10
100
P Standby
FE80::A8BB:CCFF:FE00:1010
local
FE80::5:73FF:FEA0:A

リンクローカルアドレスのみ表示されます。
やはり通常はリンクローカルアドレスを使用するようです。

RT1(config)#int e 0/1
RT1(config-if)#sh
*May 1 15:49:09.132: %HSRP-5-STATECHANGE: Ethernet0/1 Grp 10 state Active -> Init
Router(config-if)#
*May 1 15:49:11.135: %LINK-5-CHANGED: Interface Ethernet0/1, changed state to administratively down
*May 1 15:49:12.135: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to down

RT2#
*May 1 15:49:09.132: %HSRP-5-STATECHANGE: Ethernet0/1 Grp 10 state Standby -> Activ e

ipv4と同じように切り替わります。

注意点/トラブルシューティング

standby version2を指定しない

指定しないとエラーになるので必須です。

Router(config-if)#standby 10 ipv6 autoconfig
% HSRP version 2 is required for IPv6 support

ping時にIF指定

HSRPに限ったことではありませんが、
SVI 10 でなく、 vlan 10を適用しているIFを指定しても疎通確認できません。
L3SWを使用する際は意識しましょう。

Switch#ping ipv6 FE80::5:73FF:FEA0:A
Output Interface: Ethernet0/0
% IPv6 isn’t enabled on this interface
Output Interface:

所感

やはり リンクローカルアドレス 関連がipv4との大きな違いだと感じるので、
そこを忘れないようにしなければと思います。
VRRPも記事にしたいです!

最後までご覧いただきありがとうございます!
それでは良いエンジニアライフを!!

コメント

タイトルとURLをコピーしました