どうも、0 です!
今回は仮想環境にて、IPv4のOSPFv3 マルチエリア設定を検証したので、
結果をメモとして残そうと思います!
それでは行ってみましょう!
検証環境
- EVE-NG
- Cisco IOL (Router/L3SW)
検証結果
設定
(config)#router ospfv3 [process id]
(config-router)#router-id [任意のアドレス]
(config-router)#address-family ipv4 unicast
(config)#interface [任意のIF]
(config-if)#ospfv3 1 ipv4 area [area id]
※注意点としてipv6と同じように入力します。
ipv6 verは こちらの記事に記載したので、慣れてない方や思い出したい方は是非!
検証(構築)
構成
config
ipv6 unicast-routing
!
interface Loopback0
ip address 15.15.15.15 255.255.255.255
ipv6 enable
ospfv3 1 ipv4 area 0
!
interface Ethernet0/0
ip address 192.168.10.15 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 0
!
interface Ethernet0/1
ip address 192.168.20.15 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 1
router ospfv3 1
router-id 15.15.15.15
!
address-family ipv4 unicast
exit-address-family
ipv6 unicast-routing
!
interface Loopback0
ip address 16.16.16.16 255.255.255.255
ipv6 enable
ospfv3 1 ipv4 area 0
!
interface Ethernet0/0
ip address 192.168.10.16 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 0
!
interface Ethernet0/1
ip address 192.168.30.16 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 2
!
router ospfv3 1
router-id 16.16.16.16
!
address-family ipv4 unicast
exit-address-family
ipv6 unicast-routing
!
interface Loopback0
ip address 17.17.17.17 255.255.255.255
ipv6 enable
ospfv3 1 ipv4 area 1
!
interface Ethernet0/0
ip address 192.168.20.17 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 1
!
router ospfv3 1
router-id 17.17.17.17
!
address-family ipv4 unicast
exit-address-family
ipv6 unicast-routing
!
interface Loopback0
ip address 18.18.18.18 255.255.255.255
ipv6 enable
ospfv3 1 ipv4 area 2
!
interface Ethernet0/0
ip address 192.168.30.18 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 2
!
router ospfv3 1
router-id 18.18.18.18
!
address-family ipv4 unicast
exit-address-family
検証(確認)
#show ip route ospfv3
#show ospfv3 interface [任意のIF]
#show ospfv3 neighbor
#show ospfv3 database
上記で確認しました。
代表してRT15の結果を記載します。
RT15#show ip route ospfv3
16.0.0.0/32 is subnetted, 1 subnets
O 16.16.16.16 [110/10] via 192.168.10.16, 03:08:08, Ethernet0/0
17.0.0.0/32 is subnetted, 1 subnets
O 17.17.17.17 [110/10] via 192.168.20.17, 03:45:18, Ethernet0/1
18.0.0.0/32 is subnetted, 1 subnets
O IA 18.18.18.18 [110/20] via 192.168.10.16, 03:08:04, Ethernet0/0
O IA 192.168.30.0/24 [110/20] via 192.168.10.16, 03:08:04, Ethernet0/0
RT15#show ospfv3 int e 0/0
Ethernet0/0 is up, line protocol is up
Link Local Address FE80::A8BB:CCFF:FE00:F000, Interface ID 3
Internet Address 192.168.10.15/24
Area 0, Process ID 1, Instance ID 64, Router ID 15.15.15.15
Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 15.15.15.15, local address FE80::A8BB:CCFF:FE00:F000
Backup Designated router (ID) 16.16.16.16, local address FE80::A8BB:CCFF:FE01:0
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Graceful restart helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 7
Last flood scan time is 0 msec, maximum is 1 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 16.16.16.16 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
RT15#show ospfv3 int e 0/1
Ethernet0/1 is up, line protocol is up
Link Local Address FE80::A8BB:CCFF:FE00:F010, Interface ID 4
Internet Address 192.168.20.15/24
Area 1, Process ID 1, Instance ID 64, Router ID 15.15.15.15
Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 15.15.15.15, local address FE80::A8BB:CCFF:FE00:F010
Backup Designated router (ID) 17.17.17.17, local address FE80::A8BB:CCFF:FE01:1000
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Graceful restart helper support enabled
Index 1/1/2, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 7
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 17.17.17.17 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
RT15#sh ospfv3 nei
OSPFv3 1 address-family ipv4 (router-id 15.15.15.15)
Neighbor ID Pri State Dead Time Interface ID Interface
16.16.16.16 1 FULL/BDR 00:00:37 3 Ethernet0/0
17.17.17.17 1 FULL/BDR 00:00:39 3 Ethernet0/1
RT15#sh ospfv3 datab
OSPFv3 1 address-family ipv4 (router-id 15.15.15.15)
Router Link States (Area 0)
ADV Router Age Seq# Fragment ID Link count Bits
15.15.15.15 238 0x8000000A 0 1 B
16.16.16.16 1894 0x80000007 0 1 B
Net Link States (Area 0)
ADV Router Age Seq# Link ID Rtr count
15.15.15.15 238 0x80000007 3 2
Inter Area Prefix Link States (Area 0)
ADV Router Age Seq# Prefix
15.15.15.15 238 0x80000008 192.168.20.0/24
15.15.15.15 238 0x80000008 17.17.17.17/32
16.16.16.16 1894 0x80000006 18.18.18.18/32
16.16.16.16 1894 0x80000006 192.168.30.0/24
Link (Type-8) Link States (Area 0)
ADV Router Age Seq# Link ID Interface
15.15.15.15 238 0x80000008 3 Et0/0
16.16.16.16 143 0x80000007 3 Et0/0
Intra Area Prefix Link States (Area 0)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
15.15.15.15 238 0x8000000A 0 0x2001 0
15.15.15.15 238 0x80000007 3072 0x2002 3
16.16.16.16 1894 0x80000009 0 0x2001 0
Router Link States (Area 1)
ADV Router Age Seq# Fragment ID Link count Bits
15.15.15.15 238 0x80000009 0 1 B
17.17.17.17 106 0x80000008 0 1 None
Net Link States (Area 1)
ADV Router Age Seq# Link ID Rtr count
15.15.15.15 238 0x80000008 4 2
Inter Area Prefix Link States (Area 1)
ADV Router Age Seq# Prefix
15.15.15.15 238 0x80000008 192.168.10.0/24
15.15.15.15 238 0x80000007 15.15.15.15/32
15.15.15.15 238 0x80000007 16.16.16.16/32
15.15.15.15 2002 0x80000006 18.18.18.18/32
15.15.15.15 2002 0x80000006 192.168.30.0/24
Link (Type-8) Link States (Area 1)
ADV Router Age Seq# Link ID Interface
15.15.15.15 238 0x80000008 4 Et0/1
17.17.17.17 106 0x80000008 3 Et0/1
Intra Area Prefix Link States (Area 1)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
15.15.15.15 238 0x80000008 4096 0x2002 4
17.17.17.17 106 0x80000008 0 0x2001 0
注意点/トラブルシューティング
ipv6を有効にする
OSPFv3を使用する際は、ipv4のみの利用でもipv6の有効化が必要です。
Router(config)#router ospfv3 1
%OSPFv3: IPv6 routing not enabled
RT15(config-if)#ospfv3 1 ipv4 a 0
% OSPFv3: IPV6 is not enabled on this interface
show ospf ~ でも ospfv3を付けた時と同様にステータスを確認できる
検証結果ではospfv3にしておりますが、ospfでも同様な結果を得られました
例:RT15#show ospf nei
OSPFv3 1 address-family ipv4 (router-id 15.15.15.15)Neighbor ID Pri State Dead Time
Interface ID Interface
16.16.16.16 1 FULL/BDR 00:00:33 3 Ethernet0/0
17.17.17.17 1 FULL/BDR 00:00:35 3 Ethernet0/1
show ip ospfv3 は使用できない
IOLではshow ip ospfv3コマンドは使用できませんでした。
実機でも試してみたいですね。
所感
やはりospfv2との違いでちょっと戸惑いましたね、、
ipv6の使用も検討している案件であれば、使用すると思いますので、
他にも色々検証して、記事にしていきたいと思います!
最後までご覧いただきありがとうございます!
それでは良いエンジニアライフを!!
コメント