どうも、0 です!
今回は仮想環境にて、IOS DHCP Server/Client 設定を検証したので、
結果をメモとして残そうと思います!
それでは行ってみましょう!
検証環境
- EVE-NG
- Cisco IOL (Router/L3SW)
検証結果
設定
■Server
(config)#service dhcp
(config)#ip dhcp excluded-address [除外アドレス]
!
(config)#ip dhcp pool [pool名]
(dhcp-config)#network [配布address] [subnet]
(dhcp-config)#default-router [address]
!
(config)#ip route [pool向け or default] [subnet] [nexthop]
■Client
(config)#interface [対象interface]
(config-if)#ip address dhcp
■server
>service dhcp
dhcp機能を有効にします。
>ip dhcp excluded-address [除外アドレス]
dhcpにて割り当てないアドレスを設定します。
default-gatawayに設定するアドレスや管理用で使用するIP等
>ip dhcp pool [pool名]
pool名を設定します。
>network [配布address] [subnet]
配布するアドレスを設定します。
>default-router [address]
配布された端末のdefault-gatawayとなるアドレスを設定します。
■client
>ip address dhcp
dhcpでアドレスが割り当てられるように設定します。
検証(構築)
構成
config
service dhcp
!
ip dhcp excluded-address 10.100.0.254
!
ip dhcp pool test
network 10.100.0.0 255.255.255.0
default-router 10.100.0.254
!
interface Ethernet0/0
ip address 10.111.0.1 255.255.255.0
!
ip route 10.100.0.0 255.255.255.0 10.111.0.254
vlan 111
!
interface Ethernet0/0
switchport access vlan 111
switchport mode access
duplex auto
!
interface Ethernet0/2
switchport access vlan 111
switchport mode access
duplex auto
vlan 100,111
!
interface Ethernet0/0
switchport access vlan 111
switchport mode access
duplex auto
!
interface Ethernet0/1
switchport access vlan 100
switchport mode access
duplex auto
!
interface Ethernet0/2
switchport access vlan 100
switchport mode access
duplex auto
!
interface Vlan100
ip address 10.100.0.254 255.255.255.0
ip helper-address 10.111.0.1
!
interface Vlan111
ip address 10.111.0.254 255.255.255.0
interface Ethernet0/0
no switchport
ip address dhcp
client20は19と同じなので割愛します。
検証(確認)
■server
#show ip dhcp pool
#show ip dhcp bindings
■client
show ip interface brief
上記で確認しました。
DHCP#sh ip dhcp pool
Pool test :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 2
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
10.100.0.3 10.100.0.1 – 10.100.0.254 2
Current index:次に振られるIP ※1から順に振られます。
Leased:割り振っているIPの数
DHCP#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.100.0.1 0063.6973.636f.2d61. Jul 23 2023 11:39 PM Automatic
6162.622e.6363.3031.
2e33.3030.302d.4574.
302f.30
10.100.0.2 0063.6973.636f.2d61. Jul 24 2023 12:05 AM Automatic
6162.622e.6363.3031.
2e34.3030.302d.4574.
302f.30
割り振ったアドレスの情報が記載されます。
Switch#sh ip int bri
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 10.100.0.1 YES DHCP up up
Ethernet0/1 unassigned YES unset up up
Ethernet0/2 unassigned YES unset up up
Ethernet0/3 unassigned YES unset up up
Vlan100 unassigned YES unset administratively down down
10.100.0.1が割り当てられています。
注意点/トラブルシューティング
helper addressの活用
DHCPクライアント(poolから割り当てられるアドレス)が
DHCPサーバのinterfaceのアドレスと異なる場合はhelper addressを使用します。
DHCPクライアントのDHCP DISCOVER(ブロードキャスト送信)を
リレーし、サーバにユニキャストで転送する。
所感
業務で使用する機会は少ない気がしますが、
自宅で簡易的に検証する分には良いと感じました!
(DHCPサーバを実際用意するとオプションの設定しないとDHCPリレーできなかったりするんですよね…)
helper addressの動作も改めて確認出来て良かったです!
最後までご覧いただきありがとうございます!
それでは良いエンジニアライフを!!
コメント